Railway gun

Web系企業に勤めるサラリーマンが書くブログ。技術に関してだったり他の物だったりします。

RMagickのインストールエラー

他の方が開発したrailsアプリを引っ張ってきて、
自分のCentOS環境でbundle installした際に下記のエラー発生。

Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.

checking for Ruby version >= 1.8.5... yes
checking for gcc... yes
checking for Magick-config... no
Can't install RMagick 2.13.2. Can't find Magick-config
・
・
・
An error occurred while installing rmagick (2.13.2), and Bundler cannot continue.
Make sure that `gem install rmagick -v '2.13.2'` succeeds before bundling.

ImageMagickが入っていないためのようだ。

$ sudo yum install ImageMagick ImageMagick-devel
$ bundle install

・
・
Installing rmagick 2.13.2
Your bundle is complete!

無事、解決。